Monday, October 11, 2004

CruiseControl and version problems

It took me several days to track down the source of my troubles, but it turns out that the latest versions of CruiseControl, Tomcat and the JDK5 do not play together. To get a working CC build results page, I need these versions with Microsoft:

  • Windows XP SP2
  • CruiseControl 2.1.6
  • Jakarta Tomcat 5.0.27
  • Sun JDK 1.4.2_05

Possibly JDK 1.4.2 works with Tomcat 5.0.28, but I did not try that combination. I spent enough time struggling with it that once I had a working combination, I stuck with it.

Next up: — installing on production which for us is a Linux Mandrake 9 box. No one here is foolish enough to use a Microsoft server for production.

Post a Comment